Back
Degraded

Clover Partially Degraded Services

Started 3 Feb at 12:30pm MST, resolved 3 Feb at 04:39pm MST.

Core Services 1 Core Services 2 Core Services 3
Resolved

It has been reported that the issues have been resolved. Official statements are pending from Clover, but when they are available they can be found at their status portal (https://status.clover.com/).

Posted 3 Feb at 04:39pm MST.
Updated

Update - Clovers API services have recovered and they are working on remediating the device services that are unavailable or having intermittent issues.

Posted 3 Feb at 03:10pm MST.
Updated

Update - Clover engineers continue to troubleshoot the API, online dashboard, and ordering issues you may be experiencing. They are actively working towards a full resolution shortly. Thank you for your ongoing patience.

Posted 3 Feb at 02:16pm MST.
Updated

Identified - Clover is currently experiencing intermittent issues with their dashboard and API connectivity, which would impact our integrated service and their Cloud Pay display application. On-device payments should be functional. You do not need to take any action at this time. We will provide another update within the next 30 minutes.

Posted 3 Feb at 12:54pm MST.
Created

Reports of users using Clover devices stating that the payment screen is going blue or black when going to attempt a payment. Clover Dashboard is also loading very slow and mostly unusable. Clover has stated their services are degraded and we are tracking it through their status portal (https://status.clover.com/).

Posted 3 Feb at 12:30pm MST.