Back
Degraded

Clover devices going to a black screen when trying to process cards.

Started 9 Nov at 04:30pm MST, resolved 9 Nov at 07:41pm MST.

Core Services 1
Resolved

Clover functionality has been restored. All services are working now as expected.

Thank you for your ongoing patience!

Posted 9 Nov at 07:41pm MST.
Created

Clients with Clover devices are reporting issues where they are unable to process payments. The device goes to a black screen rather than processing.

Clover has identified the issue and is actively working to resolve it.

Posted 9 Nov at 04:30pm MST.